Hướng dẫn cài đặt tên miền VNCCTV lên Mikrotik RouterOS

Để cài đặt tên miền DDNS miễn phí của VNCCTV lên Router Mikrotik, bạn vui lòng sử dụng WINBOX  (Hướng dẫn sử dụng WINBOX).


Sau khi tạo tên miền mới tại https://vncctv.com/ , bạn sẽ được hệ thông cung cấp Thông số cài đặt, vui lòng giữ lại thông số để thao tác các bước tiếp theo.

Bước 1: Tạo Script cập nhật IP.

Vào Menu System -> Scripts , Bấm vào biết tượng dấu + để tạo Script mới

Mikrotik DDNS vncctv Script
Mikrotik DDNS vncctv Script
Mikrotik DDNS vncctv Script 2
Mikrotik DDNS vncctv new Script
Mikrotik DDNS vncctv Script 3
Mikrotik DDNS vncctv add Script

Ở khung New Script bạn điền theo thông tin sau:

Name: VNCCTV

SOURCE: copy đoạn script bên dưới.

Chú ý chỉnh sửa thông tin trong ngoặc kép của các dòng 

:global vncctvHOSTNAME “tenmiencuaban.vncctv.com
:global vncctvUSER “TaiKhoanVNCCTV
:global vncctvPASS “MatKhauHeThongCungCap

Sửa thông tin bôi đen bằng thông số hệ thống đã cấp cho bạn lúc ban đầu.

############# CAU HINH THONG SO TEN MIEN ###############################

:global vncctvHOSTNAME "tenmiencuaban.vncctv.com"
:global vncctvUSER "TaiKhoanVNCCTV"
:global vncctvPASS "MatKhauHeThongCungCap"

##################### CODE XU LY - KHONG CHINH SUA #########################
:log info "DynDNS: Sending UPDATE!"
:local str "/nic/update?hostname=$vncctvHOSTNAME&myip=$ddnsip&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"
/tool fetch address=dyn.homeip.vn src-path=$str mode=http user=$vncctvUSER \
password=$vncctvPASS dst-path=("/DynDNS.".$vncctvHOSTNAME)
:delay 1
:local str [/file find name="DynDNS.$vncctvHOSTNAME"];
/file remove $str

Sau đó nhấn ApplyRun Script. Sau khi nhấn Run Script bạn quay lại trang quản lý tên miền đã tạo, kiểm tra ở mục IP liên kết, nếu có địa chỉ ip thì Script đã tạo thành công.

 

Bước 2: Tạo lịch chạy Script tự động mỗi 2 phút 1 lần:

 

Vào Menu System -> Scheduler , Bấm vào biết tượng dấu + để thêm lịch chạy

Tạo Lịch chạy Script
Tạo Lịch chạy Script
Tạo Lịch chạy Script 2
Tạo Lịch chạy Script 2

Ở khung New Schedule bạn điền theo thông tin sau:

Name: DDNS UPDATE

Interval: 00:02:00

On Event: Copy đoạn Scrip bên dưới dán vào.

/system script run VNCCTV

Sau đó nhấn ApplyOK.


Tạo Lịch chạy Script 3
Tạo Lịch chạy Script 3

 

Chúc bạn thành công

Filed under: Cấu hình tên miền camera, Hướng dẫn cấu hình MikroTik Routers, Thiết bị mạngTagged with: , ,